summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in44
1 files changed, 22 insertions, 22 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8fb238e8fa..52779ecff0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1756,7 +1756,7 @@ AC_ARG_WITH(tdbsam,
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_TDBSAM)
+ AC_DEFINE(WITH_TDB_SAM)
;;
*)
AC_MSG_RESULT(no)
@@ -1767,14 +1767,15 @@ AC_ARG_WITH(tdbsam,
#################################################
# check for a LDAP password database
-AC_MSG_CHECKING(whether to use LDAP password database)
-AC_ARG_WITH(ldap,
-[ --with-ldapsam Include Experimental LDAP-Sam support (default=no)],
+AC_MSG_CHECKING(whether to use LDAP SAM database)
+AC_ARG_WITH(ldapsam,
+[ --with-ldapsam Include experimental LDAP SAM support (default=no)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_LDAP)
- AC_MSG_ERROR([LDAP password database not supported in this version.])
+ AC_DEFINE(WITH_LDAP_SAM)
+ LIBS="-lldap -llber -lresolv $LIBS"
+ with_smbpasswd_sam=no
;;
*)
AC_MSG_RESULT(no)
@@ -1784,23 +1785,22 @@ AC_ARG_WITH(ldap,
)
#################################################
-# commented out by --jerry
# check for a NISPLUS password database
-#AC_MSG_CHECKING(whether to use NISPLUS password database)
-#AC_ARG_WITH(nisplus,
-#[ --with-nisplus Include NISPLUS password database support
-#[ case "$withval" in
-# yes)
-# AC_MSG_RESULT(yes)
-# AC_DEFINE(WITH_NISPLUS)
-# ;;
-# *)
-# AC_MSG_RESULT(no)
-# ;;
-# esac ],
-# AC_MSG_RESULT(no)
-#)
-
+AC_MSG_CHECKING(whether to use NISPLUS SAM database)
+AC_ARG_WITH(nisplussam,
+[ --with-nisplussam Include NISPLUS SAM support (default=no)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_NISPLUS_SAM)
+ with_smbpasswd_sam=no
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
#################################################
# check for a NISPLUS_HOME support
AC_MSG_CHECKING(whether to use NISPLUS_HOME)