summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index b152f0b46c..50ac676bee 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2710,6 +2710,13 @@ AC_ARG_WITH(pam,
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
+ if test x"$ac_cv_header_security_pam_appl_h" = x"no"; then
+ if test x"$ac_cv_header_security_pam_modules_h" = x"no"; then
+ if test x"$ac_cv_header_security__pam_macros_h" = x"no"; then
+ AC_MSG_ERROR(--with-pam specified but no PAM headers found)
+ fi
+ fi
+ fi
AC_DEFINE(WITH_PAM,1,[Whether to include PAM support])
AUTHLIBS="$AUTHLIBS -lpam"
with_pam_for_crypt=yes