summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5ccaeb756f..78a0d2e9af 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1637,9 +1637,16 @@ AC_ARG_WITH(smbmount,
[ --with-smbmount Include SMBMOUNT (Linux only) support (default=no)],
[ case "$withval" in
yes)
- AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_SMBMOUNT)
- MPROGS="bin/smbmount bin/smbmnt bin/smbumount"
+ case "$host_os" in
+ *linux*)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_SMBMOUNT)
+ MPROGS="bin/smbmount bin/smbmnt bin/smbumount"
+ ;;
+ *)
+ AC_MSG_ERROR(not on a linux system!)
+ ;;
+ esac
;;
*)
AC_MSG_RESULT(no)