summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e9665adbcc..48057c15a5 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -33,6 +33,14 @@ AC_ARG_ENABLE(developer, [ --enable-developer turn on developer warnings a
CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -DDEBUG_PASSWORD -DDEVELOPER"
fi])
+AC_ARG_ENABLE(dmalloc, [ --enable-dmalloc enable heap debugging [default=no]])
+
+if test "x$enable_dmalloc" = xyes
+then
+ AC_DEFINE(ENABLE_DMALLOC, 1, [Define to turn on dmalloc debugging])
+ LIBS="$LIBS -ldmalloc"
+fi
+
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL