summaryrefslogtreecommitdiff
path: root/source4/pidl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'source4/pidl/Makefile.PL')
-rwxr-xr-xsource4/pidl/Makefile.PL7
1 files changed, 5 insertions, 2 deletions
diff --git a/source4/pidl/Makefile.PL b/source4/pidl/Makefile.PL
index f5cd3e4eff..8167cfd6f8 100755
--- a/source4/pidl/Makefile.PL
+++ b/source4/pidl/Makefile.PL
@@ -3,13 +3,16 @@ WriteMakefile(
'NAME' => 'Parse::Pidl',
'VERSION_FROM' => 'lib/Parse/Pidl.pm',
'EXE_FILES' => [ 'pidl' ],
- 'test' => { 'TESTS' => 'tests/*.pl' }
+ 'test' => { 'TESTS' => 'tests/*.pl' },
+ 'PMLIBDIRS' => [ 'lib/Parse/Pidl']
);
sub MY::postamble {
<<'EOT';
lib/Parse/Pidl/IDL.pm: idl.yp
- yapp -s -m 'Parse::Pidl::IDL' -o lib/Parse/Pidl/IDL.pm idl.yp
+ yapp -m 'Parse::Pidl::IDL' -o lib/Parse/Pidl/IDL.pm idl.yp
+lib/Parse/Pidl/Expr.pm: expr.yp
+ yapp -m 'Parse::Pidl::Expr' -o lib/Parse/Pidl/Expr.pm expr.yp
EOT
}