summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-07-16 19:07:09 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-07-19 13:51:17 +0200
commit35872dc24058c5e8028cb4082fd405a27835dcd1 (patch)
treead566dae5cc1a32cc9cc53b6fe509e3a5295d331 /Makefile.am
parent52ae806bd17c3c00d70bd1aed437f10f5ae51a1c (diff)
downloadsssd-35872dc24058c5e8028cb4082fd405a27835dcd1.tar.gz
sssd-35872dc24058c5e8028cb4082fd405a27835dcd1.tar.bz2
sssd-35872dc24058c5e8028cb4082fd405a27835dcd1.zip
AD: Set the bool value same as default value in opts
https://fedorahosted.org/sssd/ticket/2023 When the option values are copied using dp_opt_copy_map, the .val member is used if it's not NULL. At the same time, the bool options are never NULL, unlike integers or strings that can have special NULL-like values such as NULL_STRING. This effectively means that when copying a bool option, the .val member is always used. But in the AD maps, some .val fields were set differently from the .def_val fields. The effect was that when the AD subdomain provider was initialized from IPA subdomain provider using only the defaults, some options (notably referral chasing) were set to a value that didn't make sense for the AD provider. This patch makes sure that for all boolean option, the .val is always the same as .def_val.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 51584342..0f12072f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1055,6 +1055,7 @@ auth_tests_LDADD = \
libsss_test_common.la
ipa_ldap_opt_tests_SOURCES = \
+ src/providers/data_provider_opts.c \
src/tests/ipa_ldap_opt-tests.c
ipa_ldap_opt_tests_CFLAGS = \
$(AM_CFLAGS) \