summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2013-03-11 12:28:23 -0400
committerStephen Gallagher <sgallagh@redhat.com>2013-03-11 13:31:01 -0400
commit50fe3d79ab12b795a687b676761bef265701626a (patch)
tree18ff5036befb552ef7cf37f21351bda033875f36 /Makefile.am
parent150b76e13b7c4f3ccf1d709bf517ca2af6b2c9a2 (diff)
downloadsssd-50fe3d79ab12b795a687b676761bef265701626a.tar.gz
sssd-50fe3d79ab12b795a687b676761bef265701626a.tar.bz2
sssd-50fe3d79ab12b795a687b676761bef265701626a.zip
BUILD: Fix cmocka detection
We were not properly detecting that cmocka was unavailable. It was expecting an empty value and getting "no" instead. This patch corrects the expectation, so we will now skip building and running cmocka tests on platforms that do not have it available. Also, we were missing the cmocka header files in the distribution tarball, so 'make distcheck' was failing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2401c912..67e2bd1f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -461,6 +461,8 @@ dist_noinst_HEADERS = \
src/resolv/ares/ares_parse_txt_reply.h \
src/resolv/ares/ares_data.h \
src/tests/common.h \
+ src/tests/cmocka/common_mock.h \
+ src/tests/cmocka/common_mock_resp.h \
src/sss_client/ssh/sss_ssh_client.h \
src/lib/idmap/sss_idmap_private.h