summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-04-15 10:58:22 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-05-03 20:06:29 +0200
commit6eadbf9dab2ad9a9463dc23e91c9e2fc804c1e9b (patch)
treec83e883a959335c4168e1201e97224e07d4fce9b /Makefile.am
parente2f6326ea56217afab7623c542a237ee84eb74da (diff)
downloadsssd-6eadbf9dab2ad9a9463dc23e91c9e2fc804c1e9b.tar.gz
sssd-6eadbf9dab2ad9a9463dc23e91c9e2fc804c1e9b.tar.bz2
sssd-6eadbf9dab2ad9a9463dc23e91c9e2fc804c1e9b.zip
Add SID related calls to the NSS responder
The patch adds 4 new calls to the NSS responder: - SSS_NSS_GETSIDBYNAME - SSS_NSS_GETSIDBYID - SSS_NSS_GETNAMEBYSID - SSS_NSS_GETIDBYSID to either return the SIDs of the requested object or map the SID to the name or the POSIX ID of the related object.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 36e74cf2..bb34a962 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1227,6 +1227,7 @@ nss_srv_tests_LDFLAGS = \
-Wl,-wrap,sss_cmd_done
nss_srv_tests_LDADD = \
$(CMOCKA_LIBS) \
+ libsss_idmap.la \
libsss_util.la
test_find_uid_DEPENDENCIES = \