summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2013-08-27 11:05:05 -0400
committerSimo Sorce <simo@redhat.com>2013-08-27 14:58:10 -0400
commit78395373edc3fcf62847de2c630b656967222901 (patch)
tree03c75e374ad6c70fe93de65ec5d62e693d3c4758 /Makefile.am
parentaeb1e654c337037b6bdb350e1ec8aaa065e86794 (diff)
downloadsssd-78395373edc3fcf62847de2c630b656967222901.tar.gz
sssd-78395373edc3fcf62847de2c630b656967222901.tar.bz2
sssd-78395373edc3fcf62847de2c630b656967222901.zip
BUILD: Ignore translations when building RPMs
When we're running 'make rpms' for development purposes, the nested call to 'make distdir' ends up forcing an update of the translation pot files. With this patch, we'll automatically ignore them during (S)RPM actions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4dd8ed35..5cd99b18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1983,6 +1983,12 @@ rpmroot:
mkdir -p $(RPMBUILD)/SRPMS
rpmbrprep: dist-gzip rpmroot
+if GIT_CHECKOUT
+# When we're building RPMs from a git checkout,
+# we don't want to be bothered with translation
+# updates
+ git checkout $(srcdir)/po $(srcdir)/src/man/po
+endif
cp $(builddir)/contrib/sssd.spec $(RPMBUILD)/SPECS
cp $(distdir).tar.gz $(RPMBUILD)/SOURCES
cp $(srcdir)/contrib/*.patch $(RPMBUILD)/SOURCES