summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2013-09-26 10:27:33 +0200
committerSumit Bose <sbose@redhat.com>2013-10-15 11:36:32 +0200
commitaf4ffe1001adcc0a96897e426d26444f07af9aa1 (patch)
treeaa9c4472e67b5d74e0b71ea58b98255a468f96f8 /Makefile.am
parent65a8e6e655c22027d3e02ea697972111f2a33e33 (diff)
downloadsssd-af4ffe1001adcc0a96897e426d26444f07af9aa1.tar.gz
sssd-af4ffe1001adcc0a96897e426d26444f07af9aa1.tar.bz2
sssd-af4ffe1001adcc0a96897e426d26444f07af9aa1.zip
Add CIFS idmap plugin
https://fedorahosted.org/sssd/ticket/1534
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ff1e71e7..98a298ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,9 @@ endif
if BUILD_PAC_RESPONDER
krb5authdata_plugindir = @krb5authdatapluginpath@
endif
+if BUILD_CIFS_IDMAP_PLUGIN
+cifsplugindir = @cifspluginpath@
+endif
sssdconfdir = $(sysconfdir)/sssd
sssddatadir = $(datadir)/sssd
sssdapiplugindir = $(sssddatadir)/sssd.api.d
@@ -192,6 +195,11 @@ krb5authdata_plugin_LTLIBRARIES = \
sssd_pac_plugin.la
endif
+if BUILD_CIFS_IDMAP_PLUGIN
+cifsplugin_LTLIBRARIES = \
+ cifs_idmap_sss.la
+endif
+
noinst_LTLIBRARIES =
pkglib_LTLIBRARIES = \
@@ -1878,6 +1886,19 @@ pysss_nss_idmap_la_LDFLAGS = \
-module
endif
+if BUILD_CIFS_IDMAP_PLUGIN
+cifs_idmap_sss_la_SOURCES = \
+ src/lib/cifs_idmap_sss/cifs_idmap_sss.c
+cifs_idmap_sss_la_LIBADD = \
+ libsss_idmap.la \
+ libsss_nss_idmap.la
+cifs_idmap_sss_la_CFLAGS = \
+ $(AM_CFLAGS)
+cifs_idmap_sss_la_LDFLAGS = \
+ -avoid-version \
+ -module
+endif
+
################
# TRANSLATIONS #
################