summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-06-10 12:06:45 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-06-28 18:57:24 +0200
commitd064fef06dcbcb5f6c1be03e286b1a3433d6dfd7 (patch)
treeb9dee9fa79b9c94e939c3e372c61129f17ee301e /Makefile.am
parent7f02ba09b9481f59c309fd09a88089857e7fe79f (diff)
downloadsssd-d064fef06dcbcb5f6c1be03e286b1a3433d6dfd7.tar.gz
sssd-d064fef06dcbcb5f6c1be03e286b1a3433d6dfd7.tar.bz2
sssd-d064fef06dcbcb5f6c1be03e286b1a3433d6dfd7.zip
Add cmocka based tests for libsss_idmap
This patch implements some unit tests for the recent enhancements to libsss_idmap.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 88e29fff..62f21af6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,7 +147,8 @@ if HAVE_CMOCKA
test-io \
sss_nss_idmap-tests \
dyndns-tests \
- fqnames-tests
+ fqnames-tests \
+ test_sss_idmap
endif
check_PROGRAMS = \
@@ -1298,6 +1299,17 @@ fqnames_tests_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_sss_idmap_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ src/tests/cmocka/test_sss_idmap.c
+test_sss_idmap_CFLAGS = \
+ $(AM_CFLAGS)
+test_sss_idmap_LDADD = \
+ $(CMOCKA_LIBS) \
+ libsss_idmap.la \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
+
endif
noinst_PROGRAMS = pam_test_client