summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2000-10-26 03:31:41 +0000
committerGerald Carter <jerry@samba.org>2000-10-26 03:31:41 +0000
commit01e0d3879ef5de24a6addd0ce00bf3d4de518f7f (patch)
tree0c15b9c661ee2a05bf812f84ce8b9acac3a934aa /source3/configure.in
parentf3a20ba1f328d701749073c6595c3552fc6dc40c (diff)
downloadsamba-01e0d3879ef5de24a6addd0ce00bf3d4de518f7f.tar.gz
samba-01e0d3879ef5de24a6addd0ce00bf3d4de518f7f.tar.bz2
samba-01e0d3879ef5de24a6addd0ce00bf3d4de518f7f.zip
TDB password backend support written by Simo Sorce <simo.sorce@polimi.it>
Marked as an experimental compile time option (defaults to off) for now. jerry (This used to be commit 0435af4417b876c2ea1dd4591ae7647784c28e30)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 1644c76288..00386bcece 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1389,6 +1389,24 @@ AC_ARG_WITH(pam,
AC_MSG_RESULT(no)
)
+#################################################
+# check for a TDB password database
+AC_MSG_CHECKING(whether to use TDB password database)
+AC_ARG_WITH(tdbpwd,
+[ --with-tdbpwd Include experimental TDB password database
+ --without-tdbpwd Don't include experimental TDB password database (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_TDBPWD)
+# AC_MSG_ERROR([TDB password database not supported in this version.])
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
#################################################
# check for a LDAP password database