summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 1644c76288..00386bcece 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1389,6 +1389,24 @@ AC_ARG_WITH(pam,
AC_MSG_RESULT(no)
)
+#################################################
+# check for a TDB password database
+AC_MSG_CHECKING(whether to use TDB password database)
+AC_ARG_WITH(tdbpwd,
+[ --with-tdbpwd Include experimental TDB password database
+ --without-tdbpwd Don't include experimental TDB password database (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_TDBPWD)
+# AC_MSG_ERROR([TDB password database not supported in this version.])
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
#################################################
# check for a LDAP password database