summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2012-11-21 17:52:35 +1100
committerAndreas Schneider <asn@samba.org>2012-11-22 10:21:17 +0100
commit7626b5d9045c2b490b38dee7dd45ba7763740f83 (patch)
tree5baff2f323b4ce7f3c6a491dd71421fbcbfbcd7f /source3/configure.in
parent8a2ef49dea36b103a87cf2aa63417737dd754ce6 (diff)
downloadsamba-7626b5d9045c2b490b38dee7dd45ba7763740f83.tar.gz
samba-7626b5d9045c2b490b38dee7dd45ba7763740f83.tar.bz2
samba-7626b5d9045c2b490b38dee7dd45ba7763740f83.zip
build: Remove --enable-smbtorture, require bin/smbtorture (from waf) for make test
This simply moves this to being a side-effect of --enable-selftest. The flag was renamed from --enable-smbtorture4 in a recent patch. Make test now relies on smbtorture4, and so this code to make the dependency optional for the tests is not required any more. Andrew Bartlett Reviewed-by: Andreas Schneider <asn@samba.org>
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in24
1 files changed, 7 insertions, 17 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cd80571474..b872ab794c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -202,29 +202,21 @@ AC_ARG_WITH(profiling-data,
AC_MSG_RESULT(no)
)
-dnl Checks for programs.
-AC_ARG_ENABLE(smbtorture,
- [AS_HELP_STRING([--enable-smbtorture], [Enable building smbtorture (default=auto)])])
-
-if test x$enable_smbtorture != xno; then
- smbtorture_possible=yes
-else
- smbtorture_possible=no
-fi
-
AC_PROG_INSTALL
AC_PROG_AWK
# Check for GNU make
m4_include(../m4/check_make.m4)
AC_SAMBA_GNU_MAKE([true], [true])
+selftest_possible="yes"
+
# Check for perl
m4_include(../m4/check_perl.m4)
-AC_SAMBA_PERL([true], [smbtorture_possible=no])
+AC_SAMBA_PERL([true], [selftest_possible=no])
# Check for python
m4_include(../m4/check_python.m4)
-AC_SAMBA_PYTHON_DEVEL([true], [smbtorture_possible=no])
+AC_SAMBA_PYTHON_DEVEL([true], [selftest_possible=no])
AC_CHECK_TOOL(AR, ar)
@@ -6441,6 +6433,9 @@ AC_MSG_CHECKING(whether to enable features for selftest)
if test x"$selftest" = x"yes"; then
AC_MSG_RESULT(yes)
AC_DEFINE(ENABLE_SELFTEST, 1, [Support features needed for selftest])
+ if test x"$selftest_possible" != xyes; then
+ AC_MSG_ERROR(selftest support only possible with python, including development headers, and perl installed)
+ fi
else
AC_MSG_RESULT(no)
fi
@@ -6519,11 +6514,6 @@ fi
m4_include(../lib/zlib/zlib.m4)
-if test x$smbtorture_possible = xyes; then
- SMBTORTURE="bin/smbtorture"
- AC_SUBST(SMBTORTURE)
-fi
-
AC_SUBST(ZLIB_LIBS)
AC_SUBST(ZLIB_OBJS)
AC_ZLIB([ZLIB_OBJS=""], [