summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2001-04-11 02:02:45 +0000
committerJeremy Allison <jra@samba.org>2001-04-11 02:02:45 +0000
commit91e97f90919fdc3bd2d26a5809cc3d037dbe4b22 (patch)
treefc723edfc23724bb456747fbfbee13df1f6a52f0 /source3/configure.in
parentb541683e44ebcfdf3259325d266a60eaaf19dc95 (diff)
downloadsamba-91e97f90919fdc3bd2d26a5809cc3d037dbe4b22.tar.gz
samba-91e97f90919fdc3bd2d26a5809cc3d037dbe4b22.tar.bz2
samba-91e97f90919fdc3bd2d26a5809cc3d037dbe4b22.zip
Changed the order of -kPIC and -kpic.
Added patch from Michael Davidson <md@sco.COM> for Solaris/Unixware ACLS. Jeremy. (This used to be commit 144a2906810e8d4414d627835eb80f60bd1d88a4)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 6b84c69ef6..3d32346821 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -593,17 +593,17 @@ if test $ac_cv_prog_cc_fpic = yes; then
PICFLAG="-fpic";
fi
if test x$PICFLAG = x; then
- AC_PROG_CC_FLAG(Kpic)
- if test $ac_cv_prog_cc_Kpic = yes; then
- PICFLAG="-Kpic";
- fi
-fi
-if test x$PICFLAG = x; then
AC_PROG_CC_FLAG(KPIC)
if test $ac_cv_prog_cc_KPIC = yes; then
PICFLAG="-KPIC";
fi
fi
+if test x$PICFLAG = x; then
+ AC_PROG_CC_FLAG(Kpic)
+ if test $ac_cv_prog_cc_Kpic = yes; then
+ PICFLAG="-Kpic";
+ fi
+fi
################
@@ -1984,8 +1984,8 @@ AC_ARG_WITH(acl-support,
yes)
case "$host_os" in
- *unixware*)
- AC_MSG_RESULT(Using SVR4 ACLs)
+ *sysv5*)
+ AC_MSG_RESULT(Using UnixWare ACLs)
AC_DEFINE(HAVE_UNIXWARE_ACLS)
;;
*solaris*)