summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian-woody/scripts/unpatch-source
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian-woody/scripts/unpatch-source')
-rwxr-xr-xpackaging/Debian/debian-woody/scripts/unpatch-source20
1 files changed, 0 insertions, 20 deletions
diff --git a/packaging/Debian/debian-woody/scripts/unpatch-source b/packaging/Debian/debian-woody/scripts/unpatch-source
deleted file mode 100755
index d3681cfa50..0000000000
--- a/packaging/Debian/debian-woody/scripts/unpatch-source
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh -e
-#
-#
-
-# We want to reverse the patches in the opposite order we applied
-# them, hence the 'ls|sort -r'.
-for patch in `ls debian/patches/*.patch | sort -r`; do
- patch -p1 -R --ignore-whitespace < $patch
-done
-
-# Unused code. See comment in the patch-source script.
-
-#TMPFILE=source/VERSION.debian
-#sed -e "s/^\(SAMBA_VERSION_VENDOR_SUFFIX=\).*$/\1/" source/VERSION > ${TMPFILE}
-#mv -f ${TMPFILE} source/VERSION
-
-# Regenerate configure only if it is older than configure.in
-[ source/configure -ot source/configure.in ] && (cd source && autoheader && autoconf)
-
-exit 0